Banished is always crashing when saving
  • Banished is always crashing when saving...(the fatal error window pops up)
    I tried swiching between 64 and 32: -> didnt help
    directx 9 vs 11: -> no difference
    auto and manual save, lets the game crash


    Population around 450, i guess
    Winter 88


    PC Specs:
    i5 2500k
    GTX 780
    AsRock Z77 Extreme 4

    BTW: Awesome Game ;), couldnt stop playing, till this problem did it for me :P
    Crash.dmp
    279K
    Save7.sav
    13M
  • This bug has been assigned id 140210-00026.
  • @Grumblegrim - What patch are you talking about? I'm getting the same crash, I'll try deleting all of my old save files to see if that works.

    Thanks in advance!

    EDIT: It seems removing all of my old save files (Documents > Banished > Save) done the trick.
  • Nope, doesn't work. Value was already at 0, anyway :(
  • Mine has started doing this...more frequently...since installing the 1.0.2 patch; I *think* it's because I have both Steam and the Humble Bundle versions installed - it was perfectly fine until Steam updated a day or two ago and started pulling up the 64-bit version regardless of whether I opened it with the 32-bit exe or not. My video card is shot (and integrated, unfortunately - laptop), so I can't run 64-bit graphic programs. Sad panda.
  • Renamed my exe per this thread: http://shiningrocksoftware.com/forum/discussion/3503/force-steam-to-use-32-bit#Item_7 - after starting a new game, it hasn't crashed after an hour or so of play.
  • Didn't read the thread, in a hurry atm... just saw the title and suggest getting the beta patch. But maybe that's all in the past with the new patch or I don't know what's going on... from not having read the thread.
  • Hmm, maybe his new patch his worked from the none fixed version? But it really ruined a day long of playing for me the first time I crashed on autosave. Hasn't happened since.
  • I am having a crash with "fatal error in unknown module" when saving also. I have an auto save I can load, but then it will crash when i try to save it manually. a save from a couple hours before works ok still. when using the auto-save, i tried moving all the old saves before saving and i tried to do the reassign all workers and different video options. i had a building i was destroying so i canceled that also before reassigning workers but no luck. i cant get it to run in x32 at all (using tricks i've found) so idk if that would work. here is the auto save and the crash dump. thanks.

    MS Windows 8.1 Professional with Media Center 64-bit
    Intel Core i5 4670K
    EVGA 141-HW-E877 (Z87 FTW)
    Realtek High Definition Audio
    (Virtu MVP 2.0, but it is disabled when playing)
    EVGA NVIDIA GeForce GTX 760
    Intel(R) HD Graphics 4600

    EDIT: I continued playing from the last manual save, and I haven't had any other problems after a couple more decades of game time.
    Crash.dmp
    283K
    Auto.sav
    13M
  • Same thing is happening to me. This has happened before, so I turned off auto-saves and made several manual saves that I alternated between, hoping to pin down the error.

    I made a first save at 7:04 that works just fine, continued playing to 30 minutes, made another at 7:37, still working fine. Seven minutes later, made another save, just fine. The NEXT save after that gave me the CTD. After this triggered, loading ANY of the previous set of saves works just fine, but saving instantly crashes, even the saves that were made prior at 7:04 and 7:37 (from which I could save just fine just a few minutes earlier).

    Managed to fix it for the 7:44 save by unassigning EVERYONE. I first unassigned everyone except the teacher (because that sweet 100% education), still crashed when I tried to save. Reloaded, unassigned JUST the teacher, still crashed. It would not save until I unassigned EVERYONE.

    Loading up the successfully saved game (with everyone unassigned), game crashes again whenever I try to save with someone actually assigned to a profession. So... Really have no idea what's going on here, attached is log. I have quite a few mods loaded, so I won't upload the saves. I have encountered similar problems prior to using any mods, though.
    Crash.dmp
    259K
  • Game is crashing sometimes when saving.

    fatal error - runtime-steam-x64.dll
    Crash.dmp
    206K
  • try to pass to the 32 bits manually to see if it still crash
  • oke i have patched the game to the hotfix
    then i did a litle trying to crash it so i made a new game
    build a market on pause mode
    and saved it 3 times with no chance
    did not crashed
    then i loaded the game up (did not exit the game)
    tryed to save the game again and it crashed again

    dint add my save file sins i play with mods
    Crash.dmp
    264K
  • Playing with really large map sizes can crash the game - it runs out of it's fixed size memory usage. Working on a fix...
  • I have this problem too now, as per the thread in Bug Reports: http://shiningrocksoftware.com/forum/discussion/4428/crash-to-desktop-when-auto-saving

    I am using a few mods, but none that add buildings, resources or professions. Not using a map mod either, the game is started with the vanilla Large map.

    Have noticed that the game uses close to 256MB of memory while in normal operation, as per the Task Manager. But when the crash occurs - always while autosaving, so far - Task Manager reports around 350MB of usage for Application-x64.exe
  • but why limiting it so much, people have 4 to 8 Gigabytes of memory
  • Tried what banishedrocks304 suggested. The Video interface value already existed. Changed the Value data to 0. Was then able to save the gave.
  • well. worked once, then started crashing again.
  • playing the 32bit on same file is able to save.
  • If anyone is using the tree growth mod (http://steamcommunity.com/sharedfiles/filedetails/?id=320829114&searchtext=tree+growth) it caused the X64.dll bug crash for me, even though no conflicts are present with other mods. As soon as I disabled it, I stopped getting the crash at autosave.
  • Still happening for me too. Unmodded build 451677, crashes when (either manual or auto) saving. Latest saveable version attached.
    (I tried all the "fixes" I could find to no avail, game was started from scratch with no migration, copying to a different computer or tampering)
    Crash.dmp
    224K
    Save4.sav
    13M

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!