A fatal error has occured...
  • ... and the game cannot continue. Rather vague, I know, but apart from the crash dump location that's all it says.

    I've attached the dump file, and hopefully it's something that I can correct/work around.

    I'm not running the best laptop in the world, but I would think that it would be more than capable to safely run Banished. Figuring it may be something to do with my set-up since noone else has posted yet.

    ASUS Eee PC 1215n; Win7 HP 32-bit (6.1, Build 7601); Intel Atom 1.8GHz; NVidia Ion GPU; 4GB RAM; DirectX 11 compatible.

    It may some seem that great, but if you wish I can list what games I can run on it, both amusing and fairly impressive. Hence why I bought banished and expected it to be able to run it. That is, if it is a hardware issue.

    Happy to submit any further information I can provide. Dying to play!!
    Crash.dmp
    106K
  • Oh, and this happens directly on start-up after the screen goes white.
  • Crash dump looks like its dying starting up DX11 - you can force the game into DX9 mode with some registry editing, if you're comfortable with that. (regedit.exe)

    If you navigate to, (or you might have to add)
    HKEY_CURRENT_USER\Software\Shining Rock Software LLC\Banished

    Then add a new string value (not integer!)
    name: VideoInterface
    value: 0

    The game should then try to start in DX9 mode first.

    Edit: You can accomplish the same thing by renaming or deleting the VideoDX11-x32.dll or VideoDX11-x64.dll to something else and then starting the game.

    Do you have the latest nvidia drivers?
  • Thanks, will do that now then let you know!
    Pretty sure I do, can't find a newer one.
  • OK, I changed that string value (VideoInterface already existed) to 0 and it works fine now! Thank you very much Luke, you're clearly devoted to this and it shows, very inspiring and can't wait to get started now.
    Thanks!
  • How do you do this?
  • On the Windows start menu search for regedit as Luke says. There's a tree menu on the left, there just follow the path that he mentioned above, right click the VideoInterface string, click Modify and then change "1" to "0".

    Best of luck!
  • Can someone please give me a dumbass' guide on how to do this e.g - start, programs etc so I know how to force dx9? Really wanna play but I have no idea how to alter config files and the such...
  • i have got up to (HKEY_CURRENT_USER\Software) but there is no Shining Rock Software LLC tab any ideas, bought it through steam if that helps
  • I dont understand this and the same thing keeps on happining to me
  • Win7:

    Windows Key + R Key -> write regedit->hit Enter->navigate to, (or you might have to add)
    HKEY_CURRENT_USER\Software\Shining Rock Software LLC\Banished->right click ->new->String value->name: VideoInterface -> value data: 0
  • I've done this and still not working for me

    Mine worked the first boot, but during gameplay I had an error come up saying Windows was running out of memory and I need to close Steam. 10 seconds later it blue screened.

    I've just updated my video drivers, done this reg edit trick and uninstalled and reinstalled Banished
    Crash.dmp
    258K
  • Can you please post your pc specs?
  • Windows 8.1 64bit
    Intel i7-3612QM 2.10GHz
    16GB RAM
    NVIDIA GeForce GT 640M
  • Sounds like a memory leak
    I can't help you with this. Luke has to look in the dmp-File.
  • Gutted about it, wish I could make it work.

    Worked once, then broke entirely
  • Luke is the best. He has the advantage of knowing his game inside and out. Well done champ!
  • I am also having the same issue, and can't do the steps to solve it :( Waited so long to play this game.
  • SOLVED IT! THANKS LUKE!
  • Ok, so I've solved my issue by deleting Menu.msc and starting the game again
  • i have a HKEY_CURRENT_USER without all the back slashes and i did this and it still doesn't work is their any way to fix this?
  • Already posted in Announcement Thread.
    Posting again here to maybe help more people with similar problem as I had.


    I could not figure out how to play the game after I crashed the first time.
    (I went through the registry, updated gfx card driver and directX).

    I read from someone that it works to delete a menu file in Save Directory.
    It worked for me.

    Solution:
    Step 1. Go To Documents/Banished/Save/
    Step 2. Backup Menu.msc in a seperate folder
    Step 3. Delete Menu.msc in Documents/Banished/Save/
    Step 4. Run Banished.exe
  • Ok, I have tried everything to no avail. I keep getting the same fatal error. I made sure I had Dx9, I have set VideoInterface and renamed the .dll file and I cannot find the Save Directory to save my life.

    I am running:

    Windows 7 32-bit
    Intel i7-2640M 2.80GHz
    2GB RAM
    Standard VGA Graphics Adaptor / Intel HD Graphics 3000
    (run on Parallels for Mac)

    Any ideas slash how to find the Save Directory?
  • I have the same "crash" problem but no 'menue.msc' in my folder, there is just the crash.dmp.

    Tried the thing from kajlo but it doesn't work :/
    Crash.dmp
    198K
  • i tryed all of this but still CRD :(
    Crash.dmp
    282K
  • I have been reading all of these posts. I do not completely understand what is going on. I did change the value data on the video interface. The error message still reads "VideoDx11: No valid display modes are available! VideoDx9:The application requires hardware that supports shader model 2.0 VideoDevice: Failed to load or initialize a video interface". Please tell me what to do.
  • I have done both of these and neither of them have worked so i just losted 20$ so if you can do anything to fix this please can if not thanks Shining rock for taking 20$ of mine
  • Having pretty much the same issue as Danachos. No dmp or even a banished folder as it simply wont get passed the failed to initialize error
  • Hey I have the same problem and I don't know how fix it. I tried all solutions here and noone is working :(. My PC specs are:
    System Windows Vista
    3GB ram
    Intel Core 2 CPU 2GHz
    DirectX11
    Ati Mobility FireGL v5200
    maybe i have bad PC?
  • Hi got Fatal error after i hit in game 100 population. The same after 3 games.
    My laptop:
    Windows 7 -64bit Home Edition
    I5-2410
    DirectX11
    Nvidia GeForce GT 525M
    Tryed every moetod, and don't now the fix.

    Every one with the problem is using loptop...
    my crash file... the last one
    Crash.dmp
    260K
  • None of these are working for me either. It was fine for 42 seasons then the crash. It is however save related. Kept crashing at the same spot, (in hindsight probably during auto save) and I kept manually saving closer and closer to that time. After 4-5 saves it started crashing during manual save. Then i let it run for a bit and it kept going past the original crash point.

    We'll see if this lasts.

    For those who are lucky to get it during game try a few saves and see if you get lucky.

    I went through the regedit and the delete save file steps so try doing this 1st also.
  • If nothing is working try changing fullscreen to false in the regedit folder.

    (HKEY_CURRENT_USER\Software\Shining Rock Software LLC\Banished)


  • Ok I could NOT get my game to run at all.. all the listed tricks were not working.

    I GOT IT WORKING now tho. The shortcut made by steam doesn't work just crashes. Running it through steam doesn't work just crashes. If I go run the exe directly the game runs fantastically. (In my case, C:\Program Files (x86)\Steam\steamapps\common\Banished\Application-steam-x64.exe)

    Try this if the game won't run for you through steam!

  • The game is not playable. In each test, save the game I get the Fatal Error. Any suggestions here and on Steam, I have now tested - it does not work. Without a VERY FAST PATCH is the game unplayable!
  • I'm getting the same error. The game worked the first time I ran it, and played a new game for a couple hours, which is now on year 5 or so. Thereafter, the error appeared every time I started the game, whether through Steam or either of the executables. The registry edits and deleting the aforementioned .dlls did not help. Deleting the menu.msc file now allows me to start the game and start a new game, but the error still happens when I try to load the first game I created.
    Crash.dmp
    193K
  • I had this problem today on every startup as well (no problems yesterday). I deleted Menu.msc, this solved the problem. Radeon 7800 running Catalyst 13.12.
  • I started a game on Wednesday and everything worked fine, but I have never been able to load it, I keep getting this error.

    I tried changing the registry and removing the videoDX11-steam-x64.dll file from the folder. I tried deleting the menu file and I tried opening the game via the .exe file in the folder. None of this has worked.

    Crash.dmp
    432K
  • Same issue here. Only happens when saving.
    Crash.dmp
    296K
  • I'd be highly upset cause my place got like 400+ persons, please help with this. I've tried everything listed here.
    Crash.dmp
    272K
  • Just bought the game and cant get it started either :(
  • Same here.. The game is not working..

    Any FIX or away to get my money back??
    Crash.dmp
    275K
    2014-02-21 11_48_21-Steam.png
    432 x 211 - 15K
  • So do you have any idea when a game paid for will actually be playable or can we get a refund? I have to say I am extremely disappointed :(
  • @bilko65 you have to remember that this game was made by one developer so it will take some time for a fix. I am having the same problem but what I figured out it has to deal with saving(manually or auto).

    In both times that my town has crashed when it autosaved I have about 403+ citizens, so possibly a reason it could be crashing was having a lot of citizens and stuff going on in the town and the save couldn't keep track of it.
  • Same problem, crash on startup. Solutions in this thread or 2014-02-19 blog post don't work. I don't even get Menu.msc to delete.
    Build 140210. Here are DxDiag report and crash dump.
    ------------------
    System Information
    ------------------
    Time of this report: 2/22/2014, 00:04:17
    Operating System: Windows 7 Ultimate 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130828-1532)
    Language: Russian (Regional Setting: Russian)
    System Manufacturer: Dell Inc.
    System Model: Inspiron 1501
    BIOS: BIOS Version 2.6.3
    Processor: AMD Turion(tm) 64 X2 Mobile Technology TL-50 (2 CPUs), ~1.6GHz
    Memory: 2048MB RAM
    Available OS Memory: 1918MB RAM
    Page File: 846MB used, 2989MB available
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    DxDiag Version: 6.01.7601.17514 32bit Unicode

    ---------------
    Display Devices
    ---------------
    Card name: ATI Radeon Xpress Series
    Manufacturer: ATI Technologies Inc.
    Chip type: ATI Radeon Xpress Series (0x5975)
    DAC type: Internal DAC(400MHz)
    Device Key: Enum\PCI\VEN_1002&DEV_5975&SUBSYS_01F51028&REV_00
    Display Memory: 830 MB
    Dedicated Memory: 127 MB
    Shared Memory: 703 MB
    Current Mode: 1280 x 800 (32 bit) (60Hz)
    Monitor Name: Generic PnP Monitor
    Monitor Model: unknown
    Monitor Id: MS_0000
    Native Mode: 1280 x 800(p) (60.002Hz)
    Output Type: Internal
    Driver Name: atiumdag.dll,atiumdva.cap,atitmmxx.dll
    Driver File Version: 8.14.0010.0647 (English)
    Driver Version: 8.593.100.0
    DDI Version: 9Ex
    Driver Model: WDDM 1.0
    Driver Attributes: Final Retail
    Driver Date/Size: 2/11/2010 09:17:14, 3839488 bytes
    WHQL Logo'd: n/a
    WHQL Date Stamp: n/a
    Device Identifier: {D7B71EE2-1A35-11CF-1F71-FF21A1C2C535}
    Vendor ID: 0x1002
    Device ID: 0x5975
    SubSys ID: 0x01F51028
    Revision ID: 0x0000
    Driver Strong Name: oem6.inf:ATI.Mfg.NTx86.6.0:ati2mtag_RS482M:8.593.100.0:pci\ven_1002&dev_5975
    Rank Of Driver: 00F62001
    Video Accel: ModeMPEG2_A ModeMPEG2_C
    Deinterlace Caps: {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
    {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY
    {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
    {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY
    {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
    {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY
    D3D9 Overlay: Not Supported
    DXVA-HD: Not Supported
    DDraw Status: Enabled
    D3D Status: Enabled
    AGP Status: Enabled

    -------------
    Sound Devices
    -------------
    Description: Speakers / Headphones (SigmaTel High Definition Audio CODEC)
    Default Sound Playback: Yes
    Default Voice Playback: Yes
    Hardware ID: HDAUDIO\FUNC_01&VEN_8384&DEV_7690&SUBSYS_102801F5&REV_1022
    Manufacturer ID: 1
    Product ID: 100
    Type: WDM
    Driver Name: stwrt.sys
    Driver Version: 6.10.5614.0000 (English)
    Driver Attributes: Final Retail
    WHQL Logo'd: n/a
    Date and Size: 9/13/2007 15:46:06, 330240 bytes
    Other Files:
    Driver Provider: SigmaTel
    HW Accel Level: Basic
    Cap Flags: 0x0
    Min/Max Sample Rate: 0, 0
    Static/Strm HW Mix Bufs: 0, 0
    Static/Strm HW 3D Bufs: 0, 0
    HW Memory: 0
    Voice Management: No
    EAX(tm) 2.0 Listen/Src: No, No
    I3DL2(tm) Listen/Src: No, No
    Sensaura(tm) ZoomFX(tm): No
    Crash.dmp
    158K
  • you have a problem saving, i cant even get it started and no offense but if I pay my hard earned cash for a game on sale to the general public i frankly expect it to work no matter how many people developed it, if it does not work dont release it, or release a beta version for people to try and then when its ready they will pay.
  • I'm having the same Problem as @Panicsferd; Everytime I try to save the game (through autosave or manual save) it throws a fatal exception. My city had just made it over 400 population, like his.

    Here is my dump file.
    Crash.dmp
    265K
  • I have been silently following this thread from the start because I have the same issue. It seems that it is a known problem and I am sure the developer is working hard on it right now. I would love a fix just as much as any of the rest of you. I am sorry I don't have any helpful input other than I agree, it has to do with saving, both manual and auto.

    I would love to hear from someone who has a large population and no saving issues, but this is definitely the wrong place to be looking for such a person.

    Looking forward to a fix, even if it is temporary. Good luck to you all.
  • After not being able to play on my main city for a couple days, I finally decided to just play for the hell of it without saving. I loaded my game and shut off the autosave and it worked fine for about an hour and a half until it crashed unexpectedly, obviously unrelated to the save issue. Obviously, there is more than one issue at hand.

    This doesn't take away from my appreciation to the developer and his hard work on an amazing game. Thank you for your hard work Shining Rock Software.
  • Hey there folks.
    I've got a population of about 200 in my village. And, it works perfectly. I've got over 20 hours logged in with a bunch of different villages, and I'm having a blast. i also have two friends with villages of three hundred or even 500, all running great.

    But, I tried connecting to the game on my laptop, and everything failed. It is getting the same issue time and time again on startup. "a fatal error has occurred and the game cannot continue! a crash dump..." and it is really frustrating. I was hoping to show the game to a couple friends whilst away from my desktop, and yet all I could show them was a $20 error message.

    Not so bad for me, of course, but I really hope this issue gets solved none the less. Good luck to the developer, and thank you for the great game. And guys, hey, at least it isn't as bad as the bugs in Sim City on their first week.
  • Hello. Mine doesn't work either. I crashes a few seconds after loading the game and the proposed fixes do not work. If I pause the game there is no issue. I can then re-save the game manually but the new save file also does not work. In addition to seeing how this can be fixed, I believe there should be 2 separate and chronological autosaves (as opposed to the latter overwriting the other).

    Dump file attached.
    Crash.dmp
    230K
  • Hey Guys!

    Im Using a Acer Laptop with INTEL / NVIDIA GPU.

    Had the same problem that the game crashed immediately afters starting.

    After checking the DxDiag, i had the idea to start the game directly with my NVIDIA GPU

    The whole way:
    open your NVDIA system control and select "desktop" in your dropdown menu. Choose "run with gpu unit..".

    rightclick on the application-steam-x64 in your common/banished folder. the opening options now contain "run with gpu"
    choose your NVIDIA GPU

    Good Luck Guys

    and sorry for my bad english :p

    EDIT: the intel gpu caused the crashes- could start the game, but chrashed later then. NVIDIA works fine.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!