Construction halted
  • Hello,

    I have this problem constrution being stopped because people suddenly stops bringing materials to the construction site before builder start building.
    -I was building Tavern, and all it needed was 12 more iron before building to start. (39% complete.)
    -I have plenty iron.
    -People have enough food.
    -Except that people won't get near the construction site anymore, there's no other problem. They are living/working fine.
    -No matter how many season pass, this problem will not solve.
    -I've tried disabling all Mods before construction, it did not help.
    -In this Tavern case, they starts to pile up irons in front of the construction site though this piling up issue seems to be gone in ver 1.05 which I just updated to.

    -Instead of building Tavern, I've tried building City Hall, same thing happened. Only difference is that this time it stopped around 43%.(No piling up material issue though)

    -This bug will not happen to all buildings. When I tried building Chapel, it was finished. (I thought bug went away when the Chapel was comple, tried building Tavern, yes, again same problem...)

    -I had ver. 1.04 which is now updated to 1.05.

    I've googled this problem and seems some people are getting same bug.

    This is my first town (I just started this game couple day ago) . I hope there is a fix for this...

  • PROBLEM FIX

    It seems I found fix on this.

    DELETE and RESET the building, then start construction right away. (Don't use PAUSE).

    I deleted the building (0% complete), reset it just near it, and started construction right away, yes, everything went fine.
    From this, I'm guessing this problem occurs when I use PAUSE button for buildings and restart construction afterward.

    I had town layout done first and "pause"d all the buildings until I was ready to really build it... and that's when I hit this bug. Unlocking PAUSE to start construction.

    So anyone who PAUSEd many buildings could encounter this bug.

    I hope this helps and hope it will be fixed if it's a bug. :)
  • If this happenes again , it is because the Laborers have to much other things to do, which are of more importance. In this case you simply pause all other production and most of all stop the collecting of wood, stone, iron etc. They will quickly then supply the site that needs the materials. ;)

    Fred
  • Hmm, actually my laborers had no other things to do other than bringing material to the construction site. (I just tested to see if I had any resources assigned for my laborers to collect by cancel button under Removal and Destruction toolbar, I found none.)
    I even had my other workers reassigned to laborers to be sure I had plenty of them but found that nothing changed.
    So I'm now sure it must have been some kind of bug.
    (If the problem was like what you've said, resetting building shouldn't have solved the problem so...)

    Thanks for the reply anyway :)
  • Well, I have never heard of this being a bug, maybe under certain circumstances within your game (depending on mods or something) it could be possible. Usually it is a simple matter of either not having enough laborers or too busy laborers....Glad you found a solution though. ;)

    Have fun

    Fred

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!