PC is overheating and crash
  • hello, i have a good computer (running new game with high graphic configuration) but i play Banished my pc crash after some minutes of playing. I tried all graphic configuration even with low configuration. I have windows 8 and a GeForce GTX 660
  • Did the game output a crash dump so I can see where it's crashing?
  • No. in fact as soon as the game start fans start running at max speed and after some minutes (even secondes) the PC crash.
  • Have you tried switching to the directx 9 renderer in the video options? Does this occur with other games you have?
  • I have the same problem, and it did put out a crash file for me
    Crash.dmp
    371K
  • Yes i tried directx 9. it's the first time this problem appears on my PC
  • "fans start running at max speed"
    CPU fan or GPU? You can check the HWMonitor software to monitor your temperatures and fan speeds.
    Do you have the newest graphics drivers? Try running the game in dx9 mode and see if it also happens.
  • For me it was the CPU fan. I do have the newest graphics driver and I did try running it in dx9. My computer gets really hot for some reason and I have an i5 with a Nvidia GT 650M 2GB.
  • Same for me. On your software, HWMonitor the most significant stats to increase while playing this game was the powers of the CPU
    Package from 11W to 30W
    IA cores from 5W to 24 W
  • Any idea of what to do?
  • no idea on my end
  • I deleted this file Documents\Banished\Save\Menu.msc and it seems to work better. i will try to play and i will keep in touch if it's working well
  • @mindfuldeception
    It seems that you have a notebook (the M letter in the graphic boards model indicates it), and as you may know the cooling system in notebooks have not very good perfomance (especially under 100% load). You can try using compressed air to clean the cooling system without taking your laptop apart (dust like to gather there) but I think it would only improve just a little while not solving the main problem - too high load with the game.
    Try turning off your firewall/antivirus and other unused soft, delete Documents\Banished\Save\Menu.msc and check again.
    Sadly, it's probably the problem with the game itself and the notebook (btw that's why in many games you can find a line like "The mobile versions of the graphic cards may not be supported" - cause it's somehow problematic)
  • good to know, thank you
  • Thank you, the only thing is yes I do have a laptop but I do not have this problem running higher end games (such as witcher 2) so I think it may partially be the game on this one. But again thank you, I appreciate the advice.
  • Same. When I alt-tab to window, GPU usage spikes to 100%
  • It is posible that the game doesent't limit the maximum framerate so game causes maximum load to the GPU. And since laptops usually have poorer coling fully utilizing your GPU could lead to overheating.
    I strongly suggest enabling VSync under options. This should limit FPS to the maximum available refresh rate of your monitor.
  • Ok i played for almsot 30 min and it's working well even with all graphic configuration at highest level. So i think the Documents\Banished\Save\Menu.msc was the problem !
  • unfortunatly I have tried with both vsync on and off and the problem persists. I have deleted the Menu.msc file and this did not solve my problem either. I'm glad you got yours working pigfloyd. :)
  • so I have turned vsync on turned the graphics to pretty much the lowest they will go and deleted the menu.msc and this has seemed to keep it at a stable 165F. I am hoping there will be a fix in the future be it for a specific problem or just optimization for laptops. Thanks for the help everyone.
  • The game definitely doesn't seem to limit framerate. So depending on your GPU and rig, overheating because of 240-300fps could be an issue, even with vsync. I'm not on a laptop, btw.

    I had to set a frame limit of 120. Some might need it to be 60.

    Edit: Not saying that's the problem for the OP, but it's something to try.
  • how can you limit the framerate/fps on banished ?
  • RadeonPro for AMD/ATI
    Nvidia Inspector for Nvidia
  • Using vsync limits the framerate to 60FPS max (or your refresh rate, so it could be under 60) You won't overheat with vsync on.
  • It looks like Vsync was already enabled on my machine since it was at 60FPS (checked with FRAPS). Yet the temps were spiraling up over 100 degrees Celsius.

    Deleting Menu.msc from C:\Users\ username \Documents\Banished\Save fixed the issue, and the maximum I've seen it rise to is 85 degrees. That's a reasonable temperature on this GPU; it doesn't have a great cooler.

    Not only that, it changed the way the game Alt Tabs. Before the game was windowed but not minimized. Now the window is minimized completely as it should be.
  • Banished should have a FPS limit especially when alt-tabbed.

    In the meanwhile how can I manually set a limit on frameps ?
  • i had an issue like this,i use msi afterburner to alter my fanspeed the problem only happened when i installed the steam version,anyway my gpu temp went to over 100 celsius,because my Fanspeed stayed at 30rpm,so it seems msi afterburner stopped doing its job after starting banished steam version,i went back to the website version and have had no trouble since,dont want to recreate this for obvious reasons,may be an issue,or not,
    Just trying to help make this game even better.
    TB
  • My CPU temps rocketed over 96 Celsius today playing Banished.

    Have ordered a bigger heat sink + fan for my computer. Hopefully it get's here soon.

    Graphics card is surviving easily at 36 celsius. :D
  • Experimentally, I tried deleting that Menu.msc file, and for me, it just keeps respawning itself as soon as I start the game, so it feels a little odd that would solve the problem for someone. vcync still doesn't work for me, even forcing it via the gpu panel (vs. in-game setting). Don't you love computers ...

    Beyond that, I don't think we should be forced to use vsync just to limit fps to keep gpu from frying. Not everyone likes vsync. My CPU is fine, at least. :D
  • You need to water cool your computer, get a standard garden hose and turn it on to a slight trickle. Then drill a hole of the same diameter as the hose into the case of your computer. Then stop reading this before you do something extremely silly.
  • i think the game is just CPU intensive, i run a laptop and on most games which require high cpu my laptop will heat up. i solve the problem by playing on min settings and having various laptop cooling devices. It may help you?
  • I ended up installing a new "oversized" heatsink and fan to my CPU. That has fixed the problem.
  • I have no file named menu.msc ,what should i do?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!